Forum Message

 

 

We have moved the forum to https://forum.ngsolve.org . This is an archived version of the topics until 05/05/23. All the topics were moved to the new forum and conversations can be continued there. This forum is just kept as legacy to not invalidate old links. If you want to continue a conversation just look for the topic in the new forum.

Notice

The forum is in read only mode.

Build Netgen on Linux (CentOS)

More
2 years 3 months ago #4053 by point41
Hi Matthias,

How has the work on pip-packages been going? Is it possible to try it? I am still having problems on CentOS/Redhat and would like to see if pip might help

Thanks very much,

Valery
More
2 years 3 months ago #4058 by matthiash
Hi Valery,

There is some progress on the pip packages, we will announce them, once there are no (known) issues on our side anymore.

In the meantime you may try the (preliminary) builds on test.pypi:
Code:
pip3 install mkl pip3 install -i https://test.pypi.org/simple/ ngsolve==6.2.2105.dev126

Note, that this package may be removed at any time.

Best,
Matthias
More
2 years 3 months ago #4059 by point41
Hi Matthias,

thanks, this worked well on one of my Kubuntu 20.04 machines. Didn't work on another one with the same OS and same python3 version Python 3.8.10. The error messages are below in case it might be useful. Any idea why it worked on one but not the other machine?

In a similar way, I have been having inconsistent results running ngsolve/netgen that I built under either Kubuntu or CentOS. In general, it works on the machine I built it on, but when I copy ngsolve-install to other machines it works on some but doesn't on others. When it doesn't work, I get "Illegal instruction (core dumped)". When I run it under gdb, the crash is reported in regexp (I can provide more specifics if you like). Any ideas what may be causing this and why it varies from machine to machine?

Thanks very much,

Valery

pip3 install -i test.pypi.org/simpl
e/ ngsolve==6.2.2105.dev126
Looking in indexes: test.pypi.org/simple/
Collecting ngsolve==6.2.2105.dev126
 Downloading test-files.pythonhosted.org/packages/44/...144fdf71264dcf4b6adc
441a322efd1db4e6e7bce4f52fad407f7d759/ngsolve-6.2.2105.dev126-cp38-cp38-manylinux_2_17_x
86_64.manylinux2014_x86_64.whl (28.3 MB)
    |████████████████████████████████| 28.3 MB 1.0 MB/s  
Collecting netgen-mesher==6.2.2105.dev45
 Downloading test-files.pythonhosted.org/packages/a3/...21483e19639eb3b21e49
290499ba8610df8803517ef41ccb57dea3a0c/netgen_mesher-6.2.2105.dev45-cp38-cp38-manylinux_2
_17_x86_64.manylinux2014_x86_64.whl (37.9 MB)
    |████████████████████████████████| 37.9 MB 350 kB/s  
ERROR: Could not find a version that satisfies the requirement mkl==2021.* (from ngsolve
==6.2.2105.dev126) (from versions: none)                                                 
ERROR: No matching distribution found for mkl==2021.* (from ngsolve==6.2.2105.dev126)
Time to create page: 0.098 seconds